Skip to main content
VulnerabilityPublished Updated

CVE-2026-48142: NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_charset_module module

Affects nginxSource GCVE Database

0
Compare
Authoritative record:CVE-2026-48142· Medium 4.8

Not known to be exploited · CVSS 4.8 Medium · fixed in 1.18.0-6ubuntu14.16 : update nginx when convenient.

Data as of 5 Nov 2026, 20:34 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.18.0-6ubuntu14.16, 1.24.0-2ubuntu7.13, 1.28.0-6ubuntu1.8 +1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=resoluteOther threatsAffected
  • <1.28.3-2ubuntu1.6
Fixed in
  • 1.28.3-2ubuntu1.6
Ubuntu 25.10nginxpkg:deb/ubuntu/nginx?arch=source&distro=questingOther threatsAffected
  • <1.28.0-6ubuntu1.8
Fixed in
  • 1.28.0-6ubuntu1.8
Ubuntu 24.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=nobleOther threatsAffected
  • <1.24.0-2ubuntu7.13
Fixed in
  • 1.24.0-2ubuntu7.13
Ubuntu 22.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=jammyOther threatsAffected
  • <1.18.0-6ubuntu14.16
Fixed in
  • 1.18.0-6ubuntu14.16
Ubuntu Pro 20.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=esm-infra/focalOther threatsAffected
  • 1.16.1-0ubuntu2 – 1.18.0-0ubuntu1.7+esm4
22 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 1.12.1-0ubuntu2 – 1.14.0-0ubuntu1.11+esm5
20 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_charset_module module. When content is served or proxied through a location block with both source_charset utf-8; and a charset directive (for example, charset koi8-r;) configured, remote, unauthenticated attackers can send requests (in conjunction with conditions beyond their control) to cause a heap buffer over-read in the NGINX worker process, leading to limited disclosure of memory or a restart. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

References

Community reviews

Loading reviews…