CVE-2026-115365: OpenBao 2.3.0 before 2.6.3 Incorrect Authorization via Policy Cache Namespace Traversal
Affects openbaoSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 2.6.3 soon.
Data as of 29 Oct 2026, 13:16 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 7.5 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 6.6 |
- Patch
- Available – fixed in 2.6.3
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade openbao to 2.6.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamiopenbaopkg:bitnami/openbaoOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix for this vulnerability is available in OpenBao version 2.6.3. Users should upgrade to version 2.6.3 or later to remediate this issue. No additional mitigation steps are indicated beyond applying the official patch.
Description
OpenBao versions from 2.3.0 up to but not including 2.6.3 contain an incorrect authorization vulnerability in the ACL policy cache. This flaw allows tokens to reference policies from arbitrary namespaces via specially crafted policy names, enabling attackers to gain capabilities across namespace boundaries, including the root namespace.