Skip to main content
VulnerabilityPublished

CVE-2026-115362: OpenBao before 2.6.4 and 2.7.0 before 2.7.1 Expired AppRole SecretID Authentication Bypass

Affects openbaoSource GCVE Database

0
Compare
Authoritative record:CVE-2026-115362· Low 2.1

Not known to be exploited · CVSS 2.1 Low : upgrade to 2.7.1 or 2.6.4 when convenient.

Data as of 29 Oct 2026, 13:18 UTC

CVSS 4.0 base score
2.1Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.02.1
CNA (VulnCheck)CVSS 3.12.2
Patch
Available – fixed in 2.7.1, 2.6.4
CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade openbao to 2.7.1 or 2.6.4.

Affected software

ProductAffectedFixed in
Bitnamiopenbaopkg:bitnami/openbaoOther threatsAffected
  • <2.6.4
  • >=2.7.0 <2.7.1
Fixed in
  • 2.6.4
  • 2.7.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official fixes by upgrading OpenBao to version 2.6.4 or later, or 2.7.1 or later. These versions include the fix that enforces expiration checks on Secret IDs during AppRole authentication. No other specific mitigations are indicated.

Description

OpenBao versions before 2.6.4 and 2.7.0 before 2.7.1 contain a vulnerability in the AppRole authentication method where expired Secret IDs are not checked upon use. This flaw allows expired Secret IDs to remain valid until they are removed by a periodic tidy process, potentially enabling unauthorized login beyond the intended time-to-live (TTL).

References

Community reviews

Loading reviews…