CVE-2026-115366: OpenBao 2.3.0 before 2.6.3 Missing Root Namespace Enforcement in Plugin Catalog APIs
Affects openbaoSource GCVE Database
Not known to be exploited · CVSS 2.0 Low : upgrade to 2.6.3 when convenient.
Data as of 29 Oct 2026, 13:18 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 2.0 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 2.6 |
- Patch
- Available – fixed in 2.6.3
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade openbao to 2.6.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamiopenbaopkg:bitnami/openbaoOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and the vulnerability is fixed in OpenBao version 2.6.3. Users should upgrade to version 2.6.3 or later to remediate this issue. No additional mitigation steps are indicated by the vendor advisory.
Description
OpenBao versions from 2.3.0 up to but not including 2.6.3 have an improper authorization vulnerability in the plugin catalog APIs. This flaw allows privileged child-namespace tokens to modify plugin registrations because the /v1/sys/plugins/catalog/* endpoint is not restricted to the root namespace. Exploitation can lead to removal of existing plugin registrations, creation of invalid registrations, or unauthorized registration of installed plugins via a child namespace's sys/ mount, resulting in denial of service.