CVE-2026-115369: OpenBao 2.5.0 before 2.6.2 PKI allowed_ip_sans_cidr Bypass via CSR IP SANs
Affects openbaoSource GCVE Database
Not known to be exploited · CVSS 2.1 Low : upgrade to 2.6.2 when convenient.
Data as of 29 Oct 2026, 13:17 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 2.1 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 2.2 |
- Patch
- Available – fixed in 2.6.2
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade openbao to 2.6.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamiopenbaopkg:bitnami/openbaoOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade OpenBao to version 2.6.2 or later, where this vulnerability is fixed. Since a patch is available, applying the official fix is the recommended remediation.
Description
OpenBao versions from 2.5.0 up to but not including 2.6.2 contain a vulnerability in the PKI role allowed_ip_sans_cidr enforcement. When use_csr_sans is enabled, authenticated users with sign permission can submit a CSR containing IP SANs outside the allowed range and obtain CA-signed certificates for unauthorized IP addresses. This issue is fixed in version 2.6.2.