OpenBao 2.2.0 before 2.6.4 and 2.7.0 before 2.7.1 ACME EAB MAC Key Disclosure via Sanitized Configuration
Affects openbaoSource GCVE Database
Not known to be exploited · CVSS 2.1 Low : upgrade to 2.7.1 or 2.6.4 when convenient.
Data as of 29 Oct 2026, 13:18 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 2.1 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 3.3 |
- Patch
- Available – fixed in 2.7.1, 2.6.4
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade openbao to 2.7.1 or 2.6.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamiopenbaopkg:bitnami/openbaoOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released in OpenBao versions 2.6.4 and 2.7.1. Users should upgrade to these versions or later to remediate this vulnerability. No additional mitigation steps are specified.
Description
OpenBao versions 2.2.0 before 2.6.4 and 2.7.0 before 2.7.1 have an information disclosure vulnerability that exposes the tls_acme_eab_mac_key via the sanitized configuration endpoint. This key is used for ACME External Account Binding for TLS listener certificates, and its exposure allows unauthorized binding to the operator's ACME account. The issue is fixed in versions 2.6.4 and 2.7.1.