CVE-2026-115359: OpenBao before 2.6.4 and 2.7.0 before 2.7.1 Role-Based Rate Limit Quota Bypass via Request Parsing
Affects openbaoSource GCVE Database
Not known to be exploited · CVSS 6.3 Medium : upgrade to 2.7.1 or 2.6.4 when convenient.
Data as of 29 Oct 2026, 13:18 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 6.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 3.7 |
- Patch
- Available – fixed in 2.7.1, 2.6.4
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade openbao to 2.7.1 or 2.6.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamiopenbaopkg:bitnami/openbaoOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in OpenBao versions 2.6.4 and 2.7.1 that fixes this issue. Users should upgrade to these versions or later to remediate the vulnerability.
Description
OpenBao versions before 2.6.4 and 2.7.0 before 2.7.1 have a vulnerability in the rate limit quota subsystem. The flaw causes role resolution to fail for requests with form-encoded bodies or forwarded certificates, allowing quota rules scoped to backend-specific roles to be bypassed. This enables valid callers to repeatedly issue tokens without consuming their configured role-based rate limit budget.