Skip to main content
VulnerabilityPublished Updated

CVE-2026-53809: OpenClaw · Embedded runner policy could be confused by provider aliases

Affects openclaw-cliSource GCVE Database

0
Compare

Not known to be exploited · CVSS 3.8 Low : upgrade to 2026.4.25 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
3.8Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.09% chance of exploitation in 30 days – higher than 0% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2026.4.25
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade openclaw and openclaw-cli to 2026.4.25.

Affected software

ProductAffectedFixed in
npmopenclawAffected
  • <2026.4.25
Fixed in
  • 2026.4.25
Homebrewopenclaw-clipkg:brew/openclaw-cliOther threatsAffected
  • >=2026.1.29 <2026.4.25
Fixed in
  • 2026.4.25

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in version 2026.4.25. Until patched, avoid using provider alias routing for embedded runner tool policy. Additionally, keep channel and tool allowlists narrow, avoid sharing a Gateway between mutually untrusted users, and disable the affected feature when not needed.

Description

OpenClaw CLI has a vulnerability where the embedded runner policy can be confused by provider aliases. This means that requests using provider aliases might compare policy against an alias rather than the canonical provider identity, potentially allowing access to bundled tools outside the intended provider policy. The issue affects versions before 2026.4.25. The vulnerability has a low severity score and does not affect the trusted-operator model of OpenClaw. Mitigation includes avoiding provider alias routing for embedded runner tool policy until patched and applying general hardening measures.

References

Community reviews

Loading reviews…