OpenEMR from 7.0.1 before 8.4.0 contains a flaw in src/Common/Auth/OneTimeAuth.php that ignores the
Source GCVE Database
Not known to be exploited · CVSS 9.3 Critical : upgrade to 8.4.0 as a priority.
Data as of 8 Nov 2026, 18:04 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 9.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 9.8 |
- Patch
- Available – fixed in 8.4.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.
What to do
Upgrade openemr to 8.4.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| openemropenemr | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict access to tokens, monitor for suspicious activity related to token reuse or brute-force attempts, and consider additional access controls or rate limiting at the application or network level.
Description
OpenEMR versions from 7.0.1 up to but not including 8.4.0 contain a vulnerability in the OneTimeAuth.php component where enforcement of one-time use and maximum access count flags is bypassed. The flaw also fails to revoke consumed service authentication tokens and performs login PIN checks without rate limiting or strict comparison. This allows attackers with a captured token to replay it or brute-force the PIN, potentially opening patient portal sessions and exposing protected health information (PHI).