Skip to main content
VulnerabilityPublished Updated

CVE-2024-52316: Org.apache.tomcat:tomcat catalina: Apache Tomcat - Authentication Bypass

Affects org.apache.tomcat:tomcat-catalinaSource GCVE Database

0
Compare
Authoritative record:CVE-2024-52316· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical : upgrade to 9.0.96 as a priority.

Data as of 30 Oct 2026, 00:42 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 9.0.96, 10.1.30, 11.0.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade org.apache.tomcat:tomcat-catalina to 9.0.96; org.apache.tomcat:tomcat-catalina to 10.1.30; org.apache.tomcat:tomcat-catalina to 11.0.1.

Affected software

ProductAffectedFixed in
Mavenorg.apache.tomcat:tomcat-catalinaAffected
  • <9.0.96
Fixed in
  • 9.0.96
Mavenorg.apache.tomcat:tomcat-catalinaAffected
  • >=10.1.0-M1 <10.1.30
Fixed in
  • 10.1.30
Mavenorg.apache.tomcat:tomcat-catalinaAffected
  • >=11.0.0-M1 <11.0.1
Fixed in
  • 11.0.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade to Apache Tomcat versions 9.0.96, 10.1.30, or 11.0.1, which contain fixes for this vulnerability. Since a patch is available and official fixes have been released, applying these updates is the recommended remediation.

Description

Apache Tomcat contains an authentication bypass vulnerability (CVE-2024-52316) due to unchecked error conditions in custom Jakarta Authentication ServerAuthContext components. If such a component throws an exception during authentication without setting an HTTP failure status, authentication may incorrectly succeed. No known Jakarta Authentication components currently exhibit this behavior. The issue affects multiple Tomcat versions and is fixed in versions 9.0.96, 10.1.30, and 11.0.1.

References

Community reviews

Loading reviews…