CVE-2024-24749: Org.geoserver.web:gs web app: Classpath resource disclosure
Affects org.geoserver.web:gs-web-appSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 2.23.5 soon.
Data as of 4 Nov 2026, 17:49 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 2.23.5, 2.24.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Jul 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade org.geoserver.web:gs-web-app and org.geoserver:gs-gwc to 2.23.5; org.geoserver.web:gs-web-app and org.geoserver:gs-gwc to 2.24.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavenorg.geoserver.web:gs-web-app | Affected
| Fixed in
|
| Mavenorg.geoserver.web:gs-web-app | Affected
| Fixed in
|
| Mavenorg.geoserver:gs-gwc | Affected
| Fixed in
|
| Mavenorg.geoserver:gs-gwc | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official patches by upgrading GeoServer to version 2.23.5 or 2.24.3 or later. Alternatively, change the deployment environment by using Linux or Mac OS instead of Windows, or use Jetty or WildFly instead of Apache Tomcat. Additionally, disable anonymous access to the embedded GeoWebCache administration and status pages by modifying the filter chains in the Security > Authentication settings as described in the vendor advisory.
Description
CVE-2024-24749 is a vulnerability in GeoServer's GeoWebCache (GWC) Web Resource API when deployed on Windows with Apache Tomcat. It allows an attacker to bypass input validation and read arbitrary classpath resources, potentially leading to privilege escalation if the embedded data directory is used. This issue does not affect Linux or Mac OS deployments or those using Jetty or WildFly servers. A fix is available in GeoServer versions 2.23.5 and 2.24.3.
References
- github.com/geoserver/geoserver/security/advisories/GHSA-jhqx-5v5g-mpf3 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2024-24749 (opens in a new tab)
- github.com/GeoWebCache/geowebcache/pull/1211 (opens in a new tab)
- github.com/GeoWebCache/geowebcache/commit/c7f76bd8a1d67c3b986146e7a5e0b14dd64a8fef (opens in a new tab)
- github.com/geoserver/geoserver (opens in a new tab)
- seclists.org/fulldisclosure/2024/Feb/13 (opens in a new tab)