Org.openidentityplatform.openam:openam federation library: OpenAM SAML2 Cluster Cookie-Hash-Redirect Path has
Affects org.openidentityplatform.openam:openam-federation-librarySource GCVE Database
Not known to be exploited · CVSS 7.0 High : upgrade to 16.1.1 soon.
Data as of 28 Oct 2026, 17:11 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 16.1.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:L/VI:H/VA:N/SC:L/SI:H/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade org.openidentityplatform.openam:openam-federation-library to 16.1.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavenorg.openidentityplatform.openam:openam-federation-library | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in OpenAM federation library version 16.1.1 that addresses this vulnerability. Users should upgrade to version 16.1.1 or later to remediate the issue. No additional mitigation steps are indicated by the vendor advisory.
Description
A reflected cross-site scripting (XSS) vulnerability exists in certain federation endpoints of OpenAM when deployed in a non-default clustered configuration. This occurs due to inconsistent output encoding of user-supplied parameters in HTML responses. The vulnerability affects OpenAM federation library versions prior to 16.1.1 and does not require authentication to exploit. A fix is available in version 16.1.1.
References
- github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-fhrq-3gmx-p879 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-44793 (opens in a new tab)
- github.com/OpenIdentityPlatform/OpenAM/commit/2f5e9bf4c28a4c9e97ded6ebd75e4e1ec241c894 (opens in a new tab)
- github.com/OpenIdentityPlatform/OpenAM (opens in a new tab)
- github.com/OpenIdentityPlatform/OpenAM/releases/tag/16.1.1 (opens in a new tab)