CVE-2024-2408: PHP is vulnerable to the Marvin Attack
Affects phpSource GCVE Database
Not known to be exploited · fixed in 8.3.8 : update php when convenient.
Data as of 26 Oct 2026, 08:30 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 1.1% chance of exploitation in 30 days – higher than 66% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.3.8, 8.2.20, 8.1.29
Exploitation evidence
Disclosed: evidence found.
CVE published 12 Jun 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade php to 8.3.8, 8.2.20 or 8.1.29.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamiphppkg:bitnami/phpOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and included in OpenSSL 3.2 and backported versions. PHP Windows builds 8.1.29, 8.2.20, and 8.3.8 and later include the necessary OpenSSL patches. Users should upgrade to these PHP versions or ensure their OpenSSL libraries include the rsa_pkcs1_implicit_rejection fix to mitigate the vulnerability.
Description
PHP's openssl_private_decrypt function using PKCS1 padding is vulnerable to the Marvin Attack unless used with OpenSSL versions that include the rsa_pkcs1_implicit_rejection fix. This fix is part of OpenSSL 3.2 and backported to stable Linux distributions and recent PHP Windows builds. PHP Windows builds version 8.1.29, 8.2.20, and 8.3.8 and above include the patched OpenSSL versions that mitigate this vulnerability.
References
- github.com/php/php-src/security/advisories/GHSA-hh26-4ppw-5864 (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/PKGTQUOA2NTZ3RXN22CSAUJPIRUYRB4B/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/W45DBOH56NQDRTOM2DN2LNA2FZIMC3PK/ (opens in a new tab)
- security.netapp.com/advisory/ntap-20250321-0008/ (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2024-2408 (opens in a new tab)