CVE-2025-24530: phpmyadmin/phpmyadmin · phpMyAdmin XSS when checking tables
Affects phpmyadmin/phpmyadminSource GCVE Database
Not known to be exploited · CVSS 6.4 Medium : upgrade to 5.2.2 when convenient.
Data as of 29 Oct 2026, 22:52 UTC
Thin evidence
One scorer or none| CNA (mitre) | CVSS 3.1 | 6.4 |
|---|
- Patch
- Available – fixed in 5.2.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 23 Jan 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade phpmyadmin/phpmyadmin to 5.2.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Packagistphpmyadmin/phpmyadmin | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
An issue was discovered in phpMyAdmin 5.x before 5.2.2. An XSS vulnerability has been discovered for the check tables feature. A crafted table or database name could be used for XSS.
References
- nvd.nist.gov/vuln/detail/CVE-2025-24530 (opens in a new tab)
- github.com/phpmyadmin/phpmyadmin/commit/23c13a81709728089ff031e5b1c29b5e91baa6a7 (opens in a new tab)
- github.com/phpmyadmin/phpmyadmin (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/04/msg00016.html (opens in a new tab)
- phpmyadmin.net/security/PMASA-2025-1 (opens in a new tab)