CVE-2026-14330: pipewire security update
Affects pipewireSource GCVE Database
Not known to be exploited · CVSS 5.5 Medium : upgrade to 0.3.63-7.oe2403sp1 when convenient.
Data as of 29 Oct 2026, 10:47 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.3.63-7.oe2403sp1
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 1 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade pipewire to 0.3.63-7.oe2403sp1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 24.03-LTS-SP1pipewirepkg:rpm/openEuler/pipewire&distro=openEuler-24.03-LTS-SP1Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and users should upgrade PipeWire to version 0.3.63-7.oe2403sp1 or later to remediate this vulnerability. Applying this update will prevent exploitation of the unbounded alloca() calls in the PulseAudio protocol server and block sandbox escape attempts.
Description
PipeWire versions prior to 0.3.63-7.oe2403sp1 contain multiple unbounded alloca() calls in the PulseAudio protocol server, leading to a vulnerability (CVE-2026-14330). This flaw allows an attacker with minimal permissions inside a sandboxed environment, such as Flatpak, to escape the sandbox by exploiting PipeWire's PulseAudio compatibility layer. The attacker can load a malicious library, resulting in arbitrary code execution outside the sandbox and potential full compromise of the user's system. A fix is available in version 0.3.63-7.oe2403sp1.