CVE-2026-102270: Prior to 2.14.0, PyJWT is_pem_format is affected because lazy PEM regular expression backtracks
Affects pyjwtSource GCVE Database
Not known to be exploited · CVSS 4.4 Medium · fixed in 2.14.0 : update pyjwt when convenient.
Data as of 6 Nov 2026, 18:27 UTC
- Patch
- Available – fixed in 2.14.0
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 28 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10pyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in– |
Ubuntu Pro 16.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=esm-infra-legacy/xenialOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade PyJWT to version 2.14.0 or later, where this issue is fixed. No other mitigations are indicated.
Description
PyJWT versions prior to 2.14.0 contain a vulnerability in the is_pem_format function where a lazy regular expression causes extensive backtracking when processing malformed PEM inputs. This leads to unbounded CPU consumption, allowing an attacker to cause a denial of service. The issue is resolved in version 2.14.0.
References
- ubuntu.com/security/CVE-2026-102270 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-102270 (opens in a new tab)
- github.com/jpadilla/pyjwt/security/advisories/GHSA-jwrc-g2q2-pq5p (opens in a new tab)
- github.com/jpadilla/pyjwt/commit/8b4e233a22206b34ec1186e912e75c0b2396ac07 (opens in a new tab)
- github.com/jpadilla/pyjwt/releases/tag/2.14.0 (opens in a new tab)