Skip to main content
VulnerabilityPublished Updated

CVE-2026-102266: pyjwt vulnerabilities

Affects pyjwtSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2026-102266· High 7.4

Not known to be exploited · CVSS 7.4 High · fixed in 1.3.0-1ubuntu0.1+esm3 : patch pyjwt soon.

Data as of 27 Oct 2026, 16:13 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.3.0-1ubuntu0.1+esm3, 1.5.3+ds1-1ubuntu0.1+esm3, 1.7.1-2ubuntu2.1+esm3 +3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=resoluteOther threatsAffected
  • <2.10.1-4ubuntu1.2
Fixed in
  • 2.10.1-4ubuntu1.2
Ubuntu 24.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=nobleOther threatsAffected
  • <2.7.0-1ubuntu0.3
Fixed in
  • 2.7.0-1ubuntu0.3
Ubuntu 22.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=jammyOther threatsAffected
  • <2.3.0-1ubuntu0.5
Fixed in
  • 2.3.0-1ubuntu0.5
Ubuntu Pro 20.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=esm-infra/focalOther threatsAffected
  • <1.7.1-2ubuntu2.1+esm3
Fixed in
  • 1.7.1-2ubuntu2.1+esm3
Ubuntu Pro 18.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <1.5.3+ds1-1ubuntu0.1+esm3
Fixed in
  • 1.5.3+ds1-1ubuntu0.1+esm3
Ubuntu Pro 16.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=esm-infra-legacy/xenialOther threatsAffected
  • <1.3.0-1ubuntu0.1+esm3
Fixed in
  • 1.3.0-1ubuntu0.1+esm3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available. Users should update PyJWT to the fixed package versions provided by Ubuntu for their respective LTS releases. Standard system updates or applying Ubuntu Pro fixes will remediate these vulnerabilities. Refer to the Ubuntu security notice USN-8916-1 for detailed update instructions.

Description

Multiple vulnerabilities were discovered in PyJWT affecting various Ubuntu LTS releases. These issues involve improper validation and handling of JWK keys, PEM representations, DER public keys, and redirects when fetching key sets. Exploitation could allow attackers to forge authentication tokens or cause sensitive information disclosure. The vulnerabilities affect Ubuntu 16.04 through 26.04 LTS versions. Fixes have been released in updated package versions for all affected Ubuntu releases.

References

Community reviews

Loading reviews…