CVE-2026-102266: pyjwt vulnerabilities
Affects pyjwtSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.4 High : upgrade to 2.13.0-1ubuntu1 soon.
Data as of 27 Oct 2026, 16:13 UTC
- Patch
- Available – fixed in 2.13.0-1ubuntu1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Ubuntu pyjwt package to 2.13.0-1ubuntu1.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10pyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=stonkingOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade PyJWT to version 2.13.0-1ubuntu1 or later as provided by the Ubuntu security update USN-8916-2. Applying this official fix fully addresses the vulnerabilities. Standard system updates on Ubuntu 26.10 will install the patched package. No additional mitigation actions are required beyond applying the update.
Description
Multiple vulnerabilities were discovered in PyJWT affecting key validation and handling, potentially allowing attackers to forge authentication tokens or disclose sensitive information. These issues involve improper validation of JWK keys during HMAC verification, incorrect handling of redirects when fetching key sets, and improper recognition of certain PEM and DER public key formats. The vulnerabilities affect PyJWT versions prior to 2.13.0-1ubuntu1 and specific listed versions. Ubuntu has released a fixed package version 2.13.0-1ubuntu1 to address these issues.
References
- ubuntu.com/security/notices/USN-8916-2 (opens in a new tab)
- ubuntu.com/security/CVE-2026-102266 (opens in a new tab)
- ubuntu.com/security/CVE-2026-102267 (opens in a new tab)
- ubuntu.com/security/CVE-2026-102268 (opens in a new tab)
- ubuntu.com/security/CVE-2026-102271 (opens in a new tab)
- ubuntu.com/security/CVE-2026-102272 (opens in a new tab)
- ubuntu.com/security/CVE-2026-102273 (opens in a new tab)