Skip to main content
VulnerabilityPublished

CVE-2026-97687: python-urllib3 security update

Affects python-urllib3Source GCVE Database

0
Compare

Not known to be exploited · CVSS 7.6 High : upgrade to 1.26.18-11.oe2403sp1 soon.

Data as of 29 Oct 2026, 10:48 UTC

CVSS 4.0 base score
7.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.26.18-11.oe2403sp1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade python-urllib3 to 1.26.18-11.oe2403sp1.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP1python-urllib3pkg:rpm/openEuler/python-urllib3&distro=openEuler-24.03-LTS-SP1Other threatsAffected
  • <1.26.18-11.oe2403sp1
Fixed in
  • 1.26.18-11.oe2403sp1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security fix is available in python-urllib3 version 1.26.18-11.oe2403sp1. Users should upgrade to this version or later to resolve the issue. No additional mitigations are specified by the vendor advisory.

Description

A vulnerability in python-urllib3 versions prior to 1.26.18-11.oe2403sp1 causes target-server TLS settings to be incorrectly applied to HTTPS proxy connections. This misconfiguration allows an attacker who can intercept and impersonate the HTTPS proxy to observe or modify forwarded traffic or obtain a target TLS client certificate. The issue is fixed in version 1.26.18-11.oe2403sp1.

References

Community reviews

Loading reviews…