Skip to main content
VulnerabilityPublished

Rails patches critical Active Storage flaw with RCE potential

Source Bleeping Computer

0

Mentioned vulnerabilities

Fixed in 8.1.3.1 : patch affected systems as a priority.

Data as of 4 Aug 2026, 17:47 UTC

Severity
Critical

Rated Critical by Bleeping Computer

Patch
Available – fixed in 8.1.3.1, 8.0.5.1, 7.2.3.2

What to do

AI-suggested

A fix is available by upgrading Rails Active Storage to versions 7.2.3.2 or later, 8.0.5.1 or later, or 8.1.3.1 or later. Additionally, upgrade libvips to version 8.13 or newer. For systems running libvips 8.13 or later, administrators can temporarily disable the vulnerable functionality by setting the VIPS_BLOCK_UNTRUSTED environment variable or calling Vips.block_untrusted(true) in ruby-vips 2.2.1 or newer. Rotate the secret_key_base, database credentials, Active Storage service credentials, and any other secrets accessible to the application process after patching. No workaround exists for libvips versions prior to 8.13. ImageMagick users are not affected by this vulnerability. Web application firewall (WAF) protections are available from Akamai and may provide additional defense but should not replace patching.

Description

A critical vulnerability in the Active Storage framework can allow an unauthenticated attacker to read arbitrary files from a Rails application, and potentially escalate to remote code execution (RCE). [...]

References

Community reviews

Loading reviews…