Skip to main content
VulnerabilityPublished

CVE-2026-87802: Apache Syncope · Improper Verification of Cryptographic Signature Vulnerability

Affects syncope-coreSource GCVE Database

0
Compare
Authoritative record:CVE-2026-87802· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical · fixed in 4.0.8 : patch syncope-core as a priority.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Mavenorg.apache.syncope/syncope-corepkg:maven/org.apache.syncope/syncope-coreOther threatsAffected
  • >=3.0.0-M0 <=3.0.16
  • >=4.0.0-M0 <=4.0.7
  • >=4.1.0-M0 <=4.1.2
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Syncope to version 4.0.8 or 4.1.3, which contain fixes for this vulnerability. No other mitigations are indicated. Patch status is confirmed by the vendor advisory information.

Description

Apache Syncope contains a critical vulnerability involving improper verification of cryptographic signatures when SRA is configured for OAuth 2.0 without a JWKS URI set. This flaw allows attackers to forge arbitrary JWTs to impersonate any user and gain full access to proxied services. The issue affects versions from 3.0.0-M0 through 3.0.16, 4.0.0-M0 through 4.0.7, and 4.1.0-M0 through 4.1.2. Upgrading to versions 4.0.8 or 4.1.3 resolves the vulnerability.

References

Community reviews

Loading reviews…