Skip to main content
CVE-2024-0690VulnerabilityPublished Updated

SUSE ansible-core · security update for ansible-core

Affects SUSE ansible-coreSource GCVE Database

0
Authoritative record:CVE-2024-0690· Medium 5.0

Not known to be exploited · CVSS 5.0 Medium : upgrade the Red Hat redhat/ansible-core package to 2.16.3 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
5.0Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.16.3
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Feb 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/ansible-core package to 2.16.3.

Affected software

ProductAffectedFixed in
Red Hatredhat/ansible-corepkg:rpm/redhat/ansible-coreOther threatsAffected
  • <2.16.3
Fixed in
  • 2.16.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in ansible-core version 2.16.3. Users should update to this version or later to remediate the vulnerability. Refer to the Red Hat advisory RHSA-2024:3043 for detailed update instructions. No additional mitigation actions are indicated by the vendor.

Description

A security update for ansible-core addresses a moderate severity information leak vulnerability (CVE-2024-0690) in tasks that ignore the ANSIBLE_NO_LOG configuration. This could lead to unintended exposure of sensitive information during task execution. The vulnerability affects Red Hat Enterprise Linux 8 and related distributions. The issue is fixed in ansible-core version 2.16.3, which includes this security fix along with other bug fixes and enhancements.

References

Community reviews

Loading reviews…