Skip to main content
CVE-2026-7260VulnerabilityPublished Updated

Red Hat Security Advisory: php:7.4 security, bug fix, and enhancement update

Affects Red Hat php:7.4 security,Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-7260· Medium 5.4

Not known to be exploited · CVSS 5.4 Medium · fixed in Debian package updates : update the Debian debian/php package when convenient.

Data as of 5 Nov 2026, 23:34 UTC

CVSS 4.0 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.5.9, 8.4.24, 8.3.33 +1
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H/E:U

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade PHP and the Debian debian/php package to 8.5.9, 8.4.24, 8.3.33 or 8.2.33.

Affected software

ProductAffectedFixed in
PHP GroupPHPAffected
  • ≥ 8.5.*, < 8.5.9
Fixed in
  • 8.5.9
PHP GroupPHPAffected
  • ≥ 8.4.*, < 8.4.24
Fixed in
  • 8.4.24
PHP GroupPHPAffected
  • ≥ 8.3.*, < 8.3.33
Fixed in
  • 8.3.33
PHP GroupPHPAffected
  • ≥ 8.2.*, < 8.2.33
Fixed in
  • 8.2.33
Debiandebian/phppkg:deb/debian/phpOther threatsAffected
  • <8.2.33
  • <8.3.33
  • <8.4.24
  • <8.5.9
Fixed in
  • 8.2.33
  • 8.3.33
  • 8.4.24
  • 8.5.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an update for PHP 7.4 in Red Hat Enterprise Linux 8.10.z that includes fixes for both CVE-2026-17543 and CVE-2026-7260. Users should apply this official update promptly to remediate these vulnerabilities. Detailed update instructions are available in the Red Hat advisory at https://access.redhat.com/articles/11258. No additional mitigation steps are indicated beyond applying the provided patch.

Description

Red Hat has issued a security advisory for PHP 7.4 addressing two vulnerabilities: CVE-2026-17543, a SQL injection vulnerability in the ext-pgsql extension due to improper backslash escaping, and CVE-2026-7260, a denial of service vulnerability caused by circular symbolic links in phar archives. These issues have been backported and fixed in PHP 7.4 as part of the Red Hat Enterprise Linux 8.10.z update. The advisory rates the security impact as Important (high severity).

References

Community reviews

Loading reviews…