Skip to main content
CVE-2026-7260VulnerabilityPublished Updated

Red Hat Security Advisory: php:8.2 security, bug fix, and enhancement update

Affects Red Hat php:8.2 security,Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-7260· Medium 5.4

Not known to be exploited · CVSS 5.4 Medium · fixed in Debian package updates : update the Debian debian/php package when convenient.

Data as of 5 Nov 2026, 23:34 UTC

CVSS 4.0 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.5.9, 8.4.24, 8.3.33 +1
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H/E:U

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade PHP and the Debian debian/php package to 8.5.9, 8.4.24, 8.3.33 or 8.2.33.

Affected software

ProductAffectedFixed in
PHP GroupPHPAffected
  • ≥ 8.5.*, < 8.5.9
Fixed in
  • 8.5.9
PHP GroupPHPAffected
  • ≥ 8.4.*, < 8.4.24
Fixed in
  • 8.4.24
PHP GroupPHPAffected
  • ≥ 8.3.*, < 8.3.33
Fixed in
  • 8.3.33
PHP GroupPHPAffected
  • ≥ 8.2.*, < 8.2.33
Fixed in
  • 8.2.33
Debiandebian/phppkg:deb/debian/phpOther threatsAffected
  • <8.2.33
  • <8.3.33
  • <8.4.24
  • <8.5.9
Fixed in
  • 8.2.33
  • 8.3.33
  • 8.4.24
  • 8.5.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an updated PHP 8.2 package rebased to version 8.2.33 that addresses these vulnerabilities. Users of Red Hat Enterprise Linux 9 should apply the update available in the 9.8.z update stream to remediate these issues. Refer to Red Hat's official update article (https://access.redhat.com/articles/11258) for detailed instructions on applying the update. No additional mitigation steps are indicated by the vendor.

Description

Red Hat has issued a security advisory for PHP 8.2 addressing two vulnerabilities: a SQL injection via improper backslash escaping in the ext-pgsql extension (CVE-2026-17543) and a denial of service caused by circular symbolic links in phar archives (CVE-2026-7260). These issues are fixed by rebasing PHP to version 8.2.33 in Red Hat Enterprise Linux 9.8.z. The update is rated as having an Important security impact by Red Hat Product Security.

References

Community reviews

Loading reviews…