Red Hat Security Advisory: Red Hat Web Terminal Operator 1.16.3 release
Affects Red HatSource GCVE Database
Not known to be exploited · CVSS 6.5 Medium · fixed in Red Hat package updates : update Red Hat go-billy when convenient.
Data as of 3 Nov 2026, 04:44 UTC
- Patch
- Available – fixed in 6.0.0-alpha.1, 5.9.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 1 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade go-billy to 6.0.0-alpha.1 or 5.9.0; github.com/go-git/go-billy to 5.9.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| go-gitgo-billy | Affected
| Fixed in
|
| go-gitgo-billy | Affected
| Fixed in
|
Gogithub.com/go-git/go-billypkg:golang/github.com/go-git/go-billyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Red Hat recommends upgrading the go-billy library to version 5.9.0 or later (including 6.0.0-alpha.1+) to mitigate this vulnerability. Users of the Red Hat Web Terminal Operator should install or upgrade to version 1.16.3, which includes this fix. No other specific mitigations are noted. Patch status for the Web Terminal Operator is that version 1.16.3 has been released addressing this issue.
Description
CVE-2026-44740 is a denial of service vulnerability in the go-billy library, a Go filesystem abstraction used by Red Hat Web Terminal Operator. The flaw allows remote attackers to cause application crashes or resource exhaustion by supplying crafted or malformed input due to insufficient validation and missing safety mechanisms when processing untrusted repository data or filesystem structures. Red Hat rates this as an important severity issue impacting availability. The vulnerability is addressed in go-billy versions 5.9.0 and later.
References
- access.redhat.com/errata/RHSA-2026:94071 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-44740 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-56852 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-71556 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- redhat.atlassian.net/browse/WTO-511 (opens in a new tab)
- redhat.atlassian.net/browse/WTO-557 (opens in a new tab)
- redhat.atlassian.net/browse/WTO-586 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2026/rhsa-2026_94071.json (opens in a new tab)