Skip to main content
VulnerabilityPublished Updated

CVE-2025-46818: Redis is an open source, in-memory database that persists on disk

Affects redisSource GCVE Database

0
Compare

Not known to be exploited · public detection template (Nuclei) · CVSS 7.3 High · fixed in 7.2.11+dfsg1-0ubuntu0.2 : patch redis soon.

Data as of 6 Nov 2026, 15:24 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 7.2.11+dfsg1-0ubuntu0.2, 8.1.4+dfsg1-0ubuntu0.2
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Oct 2025

  2. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade the Ubuntu valkey to 7.2.11+dfsg1-0ubuntu0.2 (package) or 8.1.4+dfsg1-0ubuntu0.2 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.10redictpkg:deb/ubuntu/redict?arch=source&distro=stonkingOther threatsAffected
  • =7.3.6+ds-1
  • =7.3.6+ds-2
  • =7.3.6+ds-2build1
Fixed in–
Ubuntu 26.10redispkg:deb/ubuntu/redis?arch=source&distro=stonkingOther threatsAffected
  • 5:8.0.5-1 – 5:8.0.6-3
4 affected builds
Fixed in–
Ubuntu 26.04 LTSredispkg:deb/ubuntu/redis?arch=source&distro=resoluteOther threatsAffected
  • 5:8.0.2-3build1 – 5:8.0.5-1ubuntu0.1
4 affected builds
Fixed in–
Ubuntu 25.10redictpkg:deb/ubuntu/redict?arch=source&distro=questingOther threatsAffected
  • 7.3.2+ds-1 – 7.3.5+ds-1ubuntu0.2
4 affected builds
Fixed in–
Ubuntu 25.10redispkg:deb/ubuntu/redis?arch=source&distro=questingOther threatsAffected
  • 5:7.0.15-3 – 5:8.0.2-3ubuntu0.25.10.1
5 affected builds
Fixed in–
Ubuntu 25.10valkeypkg:deb/ubuntu/valkey?arch=source&distro=questingOther threatsAffected
  • <8.1.4+dfsg1-0ubuntu0.2
Fixed in
  • 8.1.4+dfsg1-0ubuntu0.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading to Redis versions 7.2.11+dfsg1-0ubuntu0.2 or 8.1.4+dfsg1-0ubuntu0.2 or later as provided by the vendor. Alternatively, restrict LUA script execution by using Access Control Lists (ACL) to block the EVAL and FUNCTION command families, preventing users from running LUA scripts until patching is possible.

Description

Redis versions 8.2.1 and below with LUA scripting enabled contain a vulnerability that allows an authenticated user to manipulate LUA objects via specially crafted scripts, potentially leading to privilege escalation. This issue affects all Redis versions with LUA scripting and is fixed in version 8.2.2. A workaround is to restrict LUA script execution using ACL to block EVAL and FUNCTION commands.

References

Community reviews

Loading reviews…