CVE-2025-46819: Redis is an open source, in-memory database that persists on disk
Affects redisSource GCVE Database
Not known to be exploited · public detection template (Nuclei) · CVSS 7.1 High · fixed in 7.2.11+dfsg1-0ubuntu0.2 : patch redis soon.
Data as of 6 Nov 2026, 15:24 UTC
- Patch
- Available – fixed in 7.2.11+dfsg1-0ubuntu0.2, 8.1.4+dfsg1-0ubuntu0.2
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 3 Oct 2025
Detectable: evidence found.
nuclei template: Redis < 8.2.1 Lua Long-String Delimiter - Out-of-Bounds Read
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade the Ubuntu valkey to 7.2.11+dfsg1-0ubuntu0.2 (package) or 8.1.4+dfsg1-0ubuntu0.2 (package).
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10redictpkg:deb/ubuntu/redict?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.10redispkg:deb/ubuntu/redis?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSredispkg:deb/ubuntu/redis?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 25.10redictpkg:deb/ubuntu/redict?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10redispkg:deb/ubuntu/redis?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10valkeypkg:deb/ubuntu/valkey?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading Redis to version 8.2.2 or later. Alternatively, if patching is not immediately possible, restrict Lua script execution by using ACLs to block the EVAL and FUNCTION command families, preventing users from running Lua scripts. This workaround reduces exposure until the official fix is deployed.
Description
Redis versions 8.2.1 and below with Lua scripting enabled contain a vulnerability that allows an authenticated user to execute specially crafted Lua scripts to read out-of-bound memory or crash the server, causing denial of service. This issue affects all Redis versions with Lua scripting and is fixed in version 8.2.2. A workaround without patching is to restrict Lua script execution using ACL to block EVAL and FUNCTION commands.
References
- ubuntu.com/security/CVE-2025-46819 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-46819 (opens in a new tab)
- github.com/redis/redis/security/advisories/GHSA-4c68-q8q8-3g4f (opens in a new tab)
- github.com/redis/redis/commit/3a1624da2449ac3dbfc4bdaed43adf77a0b7bfba (opens in a new tab)
- github.com/valkey-io/valkey/commit/6dd003e88feace83e55491f32376f6927896e31e (opens in a new tab)
- github.com/redis/redis/releases/tag/8.2.2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7893-1 (opens in a new tab)