CVE-2026-66295: Saxy's XML encoder writes the target and the content of a processing instruction into the output
Source GCVE Database
Not known to be exploited · CVSS 2.1 Low : upgrade to 1.7.0 when convenient.
Data as of 6 Nov 2026, 13:24 UTC
Thin evidence
One scorer or none| CNA (EEF) | CVSS 4.0 | 2.1 |
|---|
- Patch
- Available – fixed in 1.7.0, 4aeb80e2acc318f57bd7453ad2eafd59101a90e0
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade saxy to 1.7.0; saxy to 4aeb80e2acc318f57bd7453ad2eafd59101a90e0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| qcamsaxy | Affected
| Fixed in
|
| saxyqcam/saxy | Affected
| Fixed in
|
Hexsaxypkg:hex/saxyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should avoid using the vulnerable versions (>=0.7.0 <1.7.0) of Saxy or apply updates once available. If you cannot patch yet, applications should carefully validate or sanitize inputs used in processing instructions or avoid using Saxy.XML.processing_instruction/2 with untrusted data. Monitor vendor advisories for official remediation guidance.
Description
Saxy's XML encoder has a vulnerability where processing instructions are written verbatim without validation or escaping. This allows an attacker to inject arbitrary XML elements, attributes, or further processing instructions by manipulating the target or content fields. The flaw affects versions from 0.7.0 up to but not including 1.7.0. The impact depends on how the XML output is consumed, potentially leading to forged records, injected stylesheets, or active content execution in browsers. The CVSS score is low, reflecting limited impact and complexity.
References
- github.com/qcam/saxy/security/advisories/GHSA-f9r9-vrxq-g566 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-66295 (opens in a new tab)
- github.com/qcam/saxy/commit/4aeb80e2acc318f57bd7453ad2eafd59101a90e0 (opens in a new tab)
- github.com/qcam/saxy/commit/7266632e9407842f28ffac254c56dc41210a5690 (opens in a new tab)
- cna.erlef.org/cves/CVE-2026-66295.html (opens in a new tab)
- osv.dev/vulnerability/EEF-CVE-2026-66295 (opens in a new tab)