CVE-2026-66294: XML Injection
Source GCVE Database
Not known to be exploited · CVSS 2.1 Low : upgrade to 1.7.0 when convenient.
Data as of 6 Nov 2026, 13:24 UTC
Thin evidence
One scorer or none| CNA (EEF) | CVSS 4.0 | 2.1 |
|---|
- Patch
- Available – fixed in 1.7.0, 71d99fae12f1d6596f5edb57b71f26ba854f4d33
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade saxy to 1.7.0; saxy to 71d99fae12f1d6596f5edb57b71f26ba854f4d33.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| qcamsaxy | Affected
| Fixed in
|
| saxyqcam/saxy | Affected
| Fixed in
|
Hexsaxypkg:hex/saxyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Saxy version 1.7.0 and later. Users should upgrade to version 1.7.0 or newer to remediate this vulnerability. Applications that do not place untrusted text inside CDATA nodes are not affected. No other mitigation is required.
Description
CVE-2026-66294 is an XML injection vulnerability in the Saxy XML encoder affecting versions from 0.7.0 before 1.7.0. The vulnerability arises because the encoder's CDATA serialization does not properly handle the ]]> substring, allowing attackers to prematurely terminate CDATA sections and inject arbitrary XML markup. This can lead to forged or overridden trusted fields in XML documents such as SOAP envelopes, RSS/Atom feeds, sitemaps, SVG, or other XML exports that include untrusted text in CDATA nodes. Applications that do not place untrusted text in CDATA nodes are not affected. The CVSS score is low (2.1).
References
- github.com/qcam/saxy/security/advisories/GHSA-hq6g-j46w-wx72 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-66294 (opens in a new tab)
- github.com/qcam/saxy/commit/71d99fae12f1d6596f5edb57b71f26ba854f4d33 (opens in a new tab)
- github.com/qcam/saxy/commit/7266632e9407842f28ffac254c56dc41210a5690 (opens in a new tab)
- cna.erlef.org/cves/CVE-2026-66294.html (opens in a new tab)
- osv.dev/vulnerability/EEF-CVE-2026-66294 (opens in a new tab)