CVE-2026-66293: XML Injection
Source GCVE Database
Not known to be exploited · CVSS 2.1 Low : upgrade to 1.7.0 when convenient.
Data as of 6 Nov 2026, 13:32 UTC
Thin evidence
One scorer or none| CNA (EEF) | CVSS 4.0 | 2.1 |
|---|
- Patch
- Available – fixed in 1.7.0, 6d12ee12b9e32e86ef598b3f3cafccd1840b2f41
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade saxy to 1.7.0; saxy to 6d12ee12b9e32e86ef598b3f3cafccd1840b2f41.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| qcamsaxy | Affected
| Fixed in
|
| saxyqcam/saxy | Affected
| Fixed in
|
Hexsaxypkg:hex/saxyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, avoid serializing untrusted input within XML comments using Saxy. Consider sanitizing or rejecting comment content containing '--' sequences to prevent injection.
Description
CVE-2026-66293 is an XML injection vulnerability in the encoder component of the Saxy library. The encoder fails to properly neutralize the '--' sequence within XML comment content, allowing an attacker to prematurely close comments and inject arbitrary sibling markup. This can lead to stored cross-site scripting (XSS) when rendered as HTML or SVG, or data forgery when processed by other XML consumers. The vulnerability affects Saxy versions from 0.7.0 up to but not including 1.7.0.
References
- github.com/qcam/saxy/security/advisories/GHSA-mm3m-xwmf-v698 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-66293 (opens in a new tab)
- github.com/qcam/saxy/commit/6d12ee12b9e32e86ef598b3f3cafccd1840b2f41 (opens in a new tab)
- github.com/qcam/saxy/commit/7266632e9407842f28ffac254c56dc41210a5690 (opens in a new tab)
- cna.erlef.org/cves/CVE-2026-66293.html (opens in a new tab)
- osv.dev/vulnerability/EEF-CVE-2026-66293 (opens in a new tab)