Skip to main content
CVE-2025-62291VulnerabilityPublished

CVE-2025-62291: strongswan security update

Affects strongswanSource GCVE Database

0

Not known to be exploited · CVSS 8.1 High : upgrade to 5.7.2-21.oe2003sp4 soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 62% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.7.2-21.oe2003sp4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade strongswan to 5.7.2-21.oe2003sp4.

Affected software

ProductAffectedFixed in
openEuler:20.03-LTS-SP4strongswanpkg:rpm/openEuler/strongswan&distro=openEuler-20.03-LTS-SP4Other threatsAffected
  • <5.7.2-21.oe2003sp4
Fixed in
  • 5.7.2-21.oe2003sp4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade strongSwan to version 6.0.3 or later to remediate this issue. Versions prior to 5.7.2-21.oe2003sp4 are affected. No additional mitigation steps are indicated beyond applying the official fix.

Description

A heap-based buffer overflow vulnerability exists in the eap-mschapv2 plugin (client-side) of strongSwan before version 6.0.3. This occurs due to an integer underflow triggered by a malicious EAP-MSCHAPv2 server sending a crafted message of size 6 through 8. The vulnerability affects strongSwan versions prior to 5.7.2-21.oe2003sp4 and has a high severity rating with a CVSS score of 8.1.

References

Community reviews

Loading reviews…