Skip to main content
CVE-2026-41425VulnerabilityPublished Updated

CVE-2026-41425: Authlib · Cross-site request forging when using cache

Affects kimi-cliSource GCVE Database

0

Not known to be exploited · CVSS 5.4 Medium : upgrade to 1.33.0_1 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.3.0-1ubuntu0.1~esm2, 1.6.7-1ubuntu0.1~esm1, 1.33.0_1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade kimi-cli to 1.33.0_1; python-authlib to 1.3.0-1ubuntu0.1~esm2; python-authlib to 1.6.7-1ubuntu0.1~esm1.

Affected software

ProductAffectedFixed in
Ubuntu:Pro:24.04:LTSpython-authlibpkg:deb/ubuntu/python-authlib@1.3.0-1ubuntu0.1~esm2?arch=source&distro=esm-apps/nobleOther threatsAffected
  • <1.3.0-1ubuntu0.1~esm2
  • =1.2.1-1
  • =1.3.0-1
  • =1.3.0-1ubuntu0.1~esm1
Fixed in
  • 1.3.0-1ubuntu0.1~esm2
Ubuntu:25.10python-authlibpkg:deb/ubuntu/python-authlib@1.6.0-1?arch=source&distro=questingOther threatsAffected
  • =1.5.1-1
  • =1.5.2-1
  • =1.6.0-1
Fixed in–
Ubuntu:Pro:26.04:LTSpython-authlibpkg:deb/ubuntu/python-authlib@1.6.7-1ubuntu0.1~esm1?arch=source&distro=esm-apps/resoluteOther threatsAffected
  • <1.6.7-1ubuntu0.1~esm1
  • =1.6.0-1
  • =1.6.5-1
  • =1.6.6-1
  • =1.6.7-1
Fixed in
  • 1.6.7-1ubuntu0.1~esm1
Homebrewkimi-clipkg:brew/kimi-cliOther threatsAffected
  • >=0.40 <1.33.0_1
Fixed in
  • 1.33.0_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and can be applied through standard system updates or by using Ubuntu Pro Extended Security Maintenance (ESM) packages. Users of affected versions should update to the patched versions provided by Ubuntu. No additional mitigation is required beyond applying these official updates.

Description

Authlib's OAuth integration with Starlette clients has a cross-site request forgery (CSRF) vulnerability when using the cache parameter to store authentication state. This flaw allows attackers to trick victims into completing authorization flows initiated by the attacker. The issue affects specific versions of kimi-cli and related packages. A fix is available through system updates and Ubuntu Pro Extended Security Maintenance (ESM) packages.

References

Community reviews

Loading reviews…