CVE-2026-109383: undici vulnerable to TLS certificate validation bypass via dropped tls options in Agent
Affects undiciSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.4 High : upgrade to 6.29.1 soon.
Data as of 27 Oct 2026, 20:28 UTC
- Patch
- Available – fixed in 6.29.1, 7.30.1, 8.12.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade undici to 6.29.1; undici to 7.30.1; undici to 8.12.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npmundici | Affected
| Fixed in
|
| npmundici | Affected
| Fixed in
|
| npmundici | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade undici to version 6.29.1, 7.30.1, or 8.12.2 or later, where the Agent preserves the tls option outside the JSON clone, ensuring custom TLS verification callbacks are forwarded correctly. As a workaround, pass TLS options through connect instead of tls. For proxied EnvHttpProxyAgent destinations, use requestTls or proxyTls options. No other actions are required if these mitigations are applied.
Description
undici's Agent component improperly handles TLS options by deep cloning constructor options via JSON serialization, which drops function-valued TLS callbacks such as checkServerIdentity. This results in a TLS certificate validation bypass where custom verification logic is ignored, potentially allowing acceptance of TLS peers that should be rejected. The vulnerability affects applications using Agent as the default dispatcher for request, fetch, and setGlobalDispatcher, as well as EnvHttpProxyAgent on certain routes. Fixed in undici versions 6.29.1, 7.30.1, and 8.12.2.
References
- github.com/nodejs/undici/security/advisories/GHSA-2m5v-pch6-74hx (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-109383 (opens in a new tab)
- github.com/nodejs/undici/commit/04cb74b1db131ff8f5b4557dce811cbf5f4664b4 (opens in a new tab)
- github.com/nodejs/undici/commit/8c59f6b302898cb2e9b0f7962cd7212b6e597c9f (opens in a new tab)
- github.com/nodejs/undici/commit/f75eac00ac177f7b2e6c8bfbd52d4113164286e6 (opens in a new tab)
- cna.openjsf.org/security-advisories.html (opens in a new tab)
- github.com/nodejs/undici (opens in a new tab)
- github.com/nodejs/undici/releases/tag/v6.29.1 (opens in a new tab)
- github.com/nodejs/undici/releases/tag/v7.30.1 (opens in a new tab)
- github.com/nodejs/undici/releases/tag/v8.12.2 (opens in a new tab)