Skip to main content
CVE-2024-30261VulnerabilityPublished Updated

Undici's fetch with integrity option is too lax when algorithm is specified but hash value is in incorrect

Affects undiciSource GCVE Database

0
Compare
Authoritative record:CVE-2024-30261· Low 2.6

Not known to be exploited · CVSS 2.6 Low : upgrade to 5.28.4 when convenient.

Data as of 4 Nov 2026, 17:27 UTC

CVSS 3.1 base score
2.6Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.12.6
Patch
Available – fixed in 5.28.4, 6.11.1
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Apr 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade undici to 5.28.4; undici to 6.11.1.

Affected software

ProductAffectedFixed in
npmundiciAffected
  • <5.28.4
Fixed in
  • 5.28.4
npmundiciAffected
  • >=6.0.0 <6.11.1
Fixed in
  • 6.11.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Undici to version 5.28.4 or later, or 6.11.1 or later, where the vulnerability is fixed. Additionally, ensure that the integrity option passed to fetch cannot be tampered with by untrusted parties.

Description

Undici's fetch implementation has a vulnerability in its integrity option handling. When the integrity option is specified with an algorithm but an incorrect hash value, fetch may incorrectly accept tampered requests. This flaw allows an attacker who can alter the integrity option to bypass integrity checks. The issue is fixed in versions 5.28.4 and 6.11.1.

References

Community reviews

Loading reviews…