Skip to main content
VulnerabilityPublished Updated

CVE-2025-66168: WARNING · Users of 6.x should upgrade to 6.2.4 or later as the fix was missed in previous 6.x releases

Affects activemqSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2025-66168· Medium 5.4

Not known to be exploited · CVSS 5.4 Medium · fixed in 6.2.4 : update activemq when convenient.

Data as of 28 Oct 2026, 22:28 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.2.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10activemqpkg:deb/ubuntu/activemq?arch=source&distro=stonkingOther threatsAffected
  • =5.17.6+dfsg-2
  • =5.17.6+dfsg-2ubuntu1
Fixed in–
Ubuntu 26.04 LTSactivemqpkg:deb/ubuntu/activemq?arch=source&distro=resoluteOther threatsAffected
  • =5.17.6+dfsg-2
Fixed in–
Ubuntu 25.10activemqpkg:deb/ubuntu/activemq?arch=source&distro=questingOther threatsAffected
  • =5.17.6+dfsg-1
  • =5.17.6+dfsg-2
Fixed in–
Ubuntu 24.04 LTSactivemqpkg:deb/ubuntu/activemq?arch=source&distro=nobleOther threatsAffected
  • =5.17.2+dfsg-2
  • =5.17.6+dfsg-1
Fixed in–
Ubuntu Pro 22.04 LTSactivemqpkg:deb/ubuntu/activemq?arch=source&distro=esm-apps/jammyOther threatsAffected
  • =5.16.1-1
  • =5.16.1-1ubuntu0.1~esm1
  • =5.16.1-1ubuntu0.1
Fixed in–
Ubuntu Pro 20.04 LTSactivemqpkg:deb/ubuntu/activemq?arch=source&distro=esm-apps/focalOther threatsAffected
  • =5.15.10-1
  • =5.15.11-1
  • =5.15.11-1ubuntu0.1~esm1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

WARNING: Users of 6.x should upgrade to 6.2.4 or later as the fix was missed in previous 6.x releases. See the  following for more details: https://activemq.apache.org/security-advisories.data/CVE-2026-40046-announcement.txt https://www.cve.org/CVERecord?id=CVE-2026-40046 Original Report: Apache ActiveMQ does not properly validate the remaining length field which may lead to an overflow during the decoding of malformed packets. When this integer overflow occurs, ActiveMQ may incorrectly compute the total Remaining Length and subsequently misinterpret the payload as multiple MQTT control packets which makes the broker susceptible to unexpected behavior when interacting with non-compliant clients. This behavior violates the MQTT v3.1.1 specification, which restricts Remaining Length to a maximum of 4 bytes. The scenario occurs on established connections after the authentication process. Brokers that are not enabling mqtt transport connectors are not impacted. This issue affects Apache ActiveMQ: before 5.19.2, 6.0.0 to 6.1.8, and 6.2.0 Users are recommended to upgrade to version 5.19.2, 6.1.9, or 6.2.1, which fixes the issue.

References

Community reviews

Loading reviews…