Skip to main content
VulnerabilityPublished

CVE-2025-55754: Wso2mi · Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat

Affects wso2miSource GCVE Database

0
Compare
Authoritative record:CVE-2025-55754· Critical 9.6

Not known to be exploited · CVSS 9.6 Critical : upgrade to 4.3.0-r0 as a priority.

Data as of 7 Nov 2026, 03:50 UTC

CVSS 3.1 base score
9.6Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.3.0-r0, 4.4.0-r0, 4.5.0-r0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade wso2mi to 4.3.0-r0; wso2mi to 4.4.0-r0; wso2mi to 4.5.0-r0.

Affected software

ProductAffectedFixed in
CleanStartwso2mipkg:apk/cleanstart/wso2mi?arch=noarchOther threatsAffected
  • <4.3.0-r0
Fixed in
  • 4.3.0-r0
CleanStartwso2mipkg:apk/cleanstart/wso2mi?arch=noarchOther threatsAffected
  • <4.4.0-r0
Fixed in
  • 4.4.0-r0
CleanStartwso2mipkg:apk/cleanstart/wso2mi?arch=noarchOther threatsAffected
  • <4.5.0-r0
Fixed in
  • 4.5.0-r0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches available in wso2mi versions 4.3.0-r0, 4.4.0-r0, and 4.5.0-r0 to remediate this vulnerability. No additional mitigation steps are indicated beyond updating to these fixed versions.

Description

A critical security vulnerability (CVE-2025-55754) affects the wso2mi package due to improper neutralization of escape, meta, or control sequences in Apache Tomcat. This flaw can lead to significant impact on confidentiality, integrity, and availability. Versions prior to 4.3.0-r0, 4.4.0-r0, and 4.5.0-r0 are affected. A patch is available in these fixed versions.

References

Community reviews

Loading reviews…