Skip to main content
VulnerabilityPublished

CVE-2026-75140: Wso2mi · jsoup through 1

Affects wso2miSource GCVE Database

0
Compare
Authoritative record:CVE-2026-75140· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 4.3.0-r0 soon.

Data as of 7 Nov 2026, 03:51 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.3.0-r0, 4.4.0-r0, 4.5.0-r0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade wso2mi to 4.3.0-r0; wso2mi to 4.4.0-r0; wso2mi to 4.5.0-r0.

Affected software

ProductAffectedFixed in
CleanStartwso2mipkg:apk/cleanstart/wso2mi?arch=noarchOther threatsAffected
  • <4.3.0-r0
Fixed in
  • 4.3.0-r0
CleanStartwso2mipkg:apk/cleanstart/wso2mi?arch=noarchOther threatsAffected
  • <4.4.0-r0
Fixed in
  • 4.4.0-r0
CleanStartwso2mipkg:apk/cleanstart/wso2mi?arch=noarchOther threatsAffected
  • <4.5.0-r0
Fixed in
  • 4.5.0-r0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading to wso2mi versions 4.3.0-r0, 4.4.0-r0, or 4.5.0-r0, where the vulnerability is fixed. Since patch availability is confirmed, remediation should be prioritized to prevent denial of service.

Description

A high-severity security vulnerability (CVE-2026-75140) affects the wso2mi package due to an issue involving jsoup. The vulnerability impacts availability without affecting confidentiality or integrity. Fixed versions 4.3.0-r0, 4.4.0-r0, and 4.5.0-r0 are available.

References

Community reviews

Loading reviews…