Skip to main content
VulnerabilityPublished

CVE-2026-116540: Wso2mi · netty-tcnative 2

Affects wso2miSource GCVE Database

0
Compare
Authoritative record:CVE-2026-116540· High 8.2

Not known to be exploited · CVSS 8.2 High : upgrade to 4.3.0-r0 soon.

Data as of 7 Nov 2026, 03:51 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.2
CNA (VulnCheck)CVSS 3.15.9
Patch
Available – fixed in 4.3.0-r0, 4.4.0-r0, 4.5.0-r0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade wso2mi to 4.3.0-r0; wso2mi to 4.4.0-r0; wso2mi to 4.5.0-r0.

Affected software

ProductAffectedFixed in
CleanStartwso2mipkg:apk/cleanstart/wso2mi?arch=noarchOther threatsAffected
  • <4.3.0-r0
Fixed in
  • 4.3.0-r0
CleanStartwso2mipkg:apk/cleanstart/wso2mi?arch=noarchOther threatsAffected
  • <4.4.0-r0
Fixed in
  • 4.4.0-r0
CleanStartwso2mipkg:apk/cleanstart/wso2mi?arch=noarchOther threatsAffected
  • <4.5.0-r0
Fixed in
  • 4.5.0-r0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and fixed versions 4.3.0-r0, 4.4.0-r0, and 4.5.0-r0 should be applied to remediate this vulnerability. Users should upgrade to these versions to mitigate the risk.

Description

A security vulnerability identified as CVE-2026-116540 affects the wso2mi package due to an issue in netty-tcnative 2. The vulnerability has a CVSS 3.1 base score of 5.9, indicating medium severity. It impacts availability but does not affect confidentiality or integrity. Fixed versions are available starting from 4.3.0-r0, 4.4.0-r0, and 4.5.0-r0.

References

Community reviews

Loading reviews…