Skip to main content
VulnerabilityPublished

CVE-2025-5878: Wso2mi · vulnerability was found in ESAPI esapi-java-legacy and classified as problematic

Affects wso2miSource GCVE Database

0
Compare
Authoritative record:CVE-2025-5878· Medium 6.9

Public exploit available · CVSS 6.9 Medium : upgrade to 4.3.0-r0 as a priority.

Data as of 7 Nov 2026, 03:50 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulDB)CVSS 4.06.9
CNA (VulDB)CVSS 3.17.3
CNA (VulDB)CVSS 3.07.3
CNA (VulDB)CVSS 2.07.5
Patch
Available – fixed in 4.3.0-r0, 4.4.0-r0, 4.5.0-r0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade wso2mi to 4.3.0-r0; wso2mi to 4.4.0-r0; wso2mi to 4.5.0-r0.

Affected software

ProductAffectedFixed in
CleanStartwso2mipkg:apk/cleanstart/wso2mi?arch=noarchOther threatsAffected
  • <4.3.0-r0
Fixed in
  • 4.3.0-r0
CleanStartwso2mipkg:apk/cleanstart/wso2mi?arch=noarchOther threatsAffected
  • <4.4.0-r0
Fixed in
  • 4.4.0-r0
CleanStartwso2mipkg:apk/cleanstart/wso2mi?arch=noarchOther threatsAffected
  • <4.5.0-r0
Fixed in
  • 4.5.0-r0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released in versions 4.3.0-r0, 4.4.0-r0, and 4.5.0-r0 of the wso2mi package. Users should upgrade to these fixed versions to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

A security vulnerability identified as CVE-2025-5878 affects the wso2mi package due to an issue in the ESAPI esapi-java-legacy component. The vulnerability has a high severity score of 7.3 and impacts confidentiality, integrity, and availability. Fixed versions are available starting from 4.3.0-r0, 4.4.0-r0, and 4.5.0-r0.

References

Community reviews

Loading reviews…