Skip to main content
VulnerabilityPublished

CVE-2026-71497: Wso2mi · jsoup is a Java library for working with real-world HTML

Affects wso2miSource GCVE Database

0
Compare
Authoritative record:CVE-2026-71497· Medium 4.7

Not known to be exploited · CVSS 4.7 Medium : upgrade to 4.3.0-r0 when convenient.

Data as of 7 Nov 2026, 03:51 UTC

CVSS 3.1 base score
4.7Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.3.0-r0, 4.4.0-r0, 4.5.0-r0
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade wso2mi to 4.3.0-r0; wso2mi to 4.4.0-r0; wso2mi to 4.5.0-r0.

Affected software

ProductAffectedFixed in
CleanStartwso2mipkg:apk/cleanstart/wso2mi?arch=noarchOther threatsAffected
  • <4.3.0-r0
Fixed in
  • 4.3.0-r0
CleanStartwso2mipkg:apk/cleanstart/wso2mi?arch=noarchOther threatsAffected
  • <4.4.0-r0
Fixed in
  • 4.4.0-r0
CleanStartwso2mipkg:apk/cleanstart/wso2mi?arch=noarchOther threatsAffected
  • <4.5.0-r0
Fixed in
  • 4.5.0-r0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official fixes by upgrading to wso2mi versions 4.3.0-r0, 4.4.0-r0, or 4.5.0-r0 as appropriate. Since patches are available, remediation should be performed promptly to address the vulnerability.

Description

CVE-2026-71497 is a medium severity security vulnerability affecting the wso2mi package, which uses the jsoup Java library for processing HTML. The vulnerability impacts versions prior to 4.3.0-r0, 4.4.0-r0, and 4.5.0-r0. It has a CVSS score of 4.7 with network attack vector, high attack complexity, no privileges required, and requires user interaction. The vulnerability results in limited confidentiality and integrity impact but no availability impact. Fixed versions are available.

References

Community reviews

Loading reviews…