The Pronamic Pay WordPress plugin versions before 11.1.0 and the Pronamic Pay doneren met Mollie WordPress plugin versions before 1.7.1 do not restrict access to stored form submissions via the REST API. This allows unauthenticated users to read messages submitted by visitors through the bundled forms.
The Antom Payments WordPress plugin up to version 2.0.11 has a vulnerability where it does not verify ownership or authorization before disclosing an order's confirmation link containing a secret key. This flaw allows unauthenticated attackers to access sensitive customer order details such as name, address, phone number, and email.
The npm package @htooayelwinict/travis234 version 3.3.2 contains malicious code that fully compromises any computer on which it is installed or running. The compromise includes potential unauthorized access to all secrets and keys stored on the affected system. Immediate removal of the package and rotation of all secrets and keys from a different, uncompromised computer is strongly advised. However, removal of the package alone may not eliminate all malicious software introduced by this package.
The Userplace WordPress plugin versions up to 1.2.0 contains an authorization bypass vulnerability due to missing authorization checks on an AJAX action accessible to unauthenticated users. The nonce protecting this action is publicly exposed, enabling attackers to create administrator accounts or modify site options, potentially resulting in full site takeover.
A vulnerability in the Sync Post With Other Site WordPress plugin before version 1.9.4 allows users with Contributor-level access or higher to improperly authorize content-management actions on post types other than pages. This enables such users to create and modify arbitrary custom post types, including changing content authorship.
A SQL injection vulnerability exists in the Productive Commerce WordPress plugin before version 1.1.54. This flaw arises because the plugin does not properly sanitize and escape a parameter before using it in a SQL statement, allowing unauthenticated attackers to perform SQL injection attacks.
The Ecommerce Affiliate WordPress plugin versions up to 1.0.0 contain an improper authentication vulnerability. This flaw allows unauthenticated attackers to request and verify one-time passwords for any account without restriction, enabling account takeover including administrator accounts.
The Thanh Toán Quét Mã QR Code Tự Động WordPress plugin up to version 2.0.1 has an improper access control vulnerability. This flaw allows unauthenticated attackers to mark arbitrary WooCommerce orders as paid by exploiting the lack of verification on incoming bank-transfer payment notifications in a default installation.
A SQL injection vulnerability exists in the Razorpay for WooCommerce WordPress plugin versions before 4.8.9. The flaw arises because the plugin does not properly sanitize and escape data derived from incoming webhook requests before using it in SQL queries. This vulnerability can be exploited by users who have access to the webhook secret, typically administrators, to perform SQL injection attacks.
A missing authorization vulnerability in the Razorpay for WooCommerce WordPress plugin before version 4.8.9 allows unauthenticated attackers to execute REST route requests as arbitrary user accounts. This requires the presence of a specific coupon feature to be active on the site. The issue is fixed in version 4.8.9.
A vulnerability in the Razorpay for WooCommerce WordPress plugin before version 4.8.9 allows unauthenticated attackers to disclose the monetary value of arbitrary customer orders. This occurs because the plugin does not verify ownership of an order before returning the coupon discount computed against that order. The issue is fixed in version 4.8.9.
BackUpWordPress plugin versions before 3.15 contain a vulnerability where an AJAX action that cleans up the backup directory lacks proper capability or nonce checks. This flaw allows any authenticated user with Subscriber or higher privileges to delete backup protection and working files, potentially disrupting backups and removing download protection from stored backups.
The Turisbook Booking System WordPress plugin up to version 1.3.8 contains a vulnerability that allows unauthenticated users to perform stored Cross-Site Scripting (XSS) attacks against administrators. This occurs because the plugin lacks authorization and CSRF checks when saving settings and fails to properly sanitize and escape one of the settings before outputting it on an admin page.
Contact Form 7 versions before 6.2.4 allow unauthenticated users to upload arbitrary files without validating file type or extension. A flaw in temporary-file cleanup leaves these files on disk. On certain Apache configurations (Debian/Ubuntu with directory listing and .phar mapped to PHP), this can lead to remote code execution. On other configurations, the impact is limited to arbitrary file upload that may be served as active content from the uploads directory.
The Pie Register WordPress plugin versions up to 3.8.4.15 contains a missing authorization check in one of its AJAX actions. This flaw allows users with a contributor role to modify invitation-code records created by administrators.