A type confusion vulnerability exists in Wasmtime versions before 24.0.12, 25.0.0 before 36.0.13, 37.0.0 before 46.0.2, and 47.0.0 before 47.0.3. This flaw arises because several Store APIs do not validate that objects belong to the Store's Engine. When embedders mix objects between Engines using Instance::new, StructRefPre::new, or Tag::new, it can cause trampoline signature mismatches leading to out-of-bounds stack writes, garbage collector heap corruption, or program panics. The vulnerability has a low CVSS score of 3.8 and requires high privileges and user interaction to exploit.
A denial of service vulnerability exists in rust-wasmtime versions before 36.0.16, 37.0.0 before 48.0.3, and 49.0.0 before 49.0.1. The flaw is in wasmtime-wasi where guest WASI programs can cause the host to panic by overflowing filesystem timestamp fields. Specifically, attackers can pass atim or mtim values with sub-second fields that overflow the seconds field to certain filesystem time-setting functions, crashing the host process.
Wasmtime before 24.0.13, 25.0.0 before 36.0.14, 37.0.0 before 46.0.3, and 47.0.0 before 47.0.4 allows a filesystem sandbox escape in wasmtime-wasi because its cap-std dependency mishandles symlinks with trailing slashes on macOS and Linux kernels lacking openat2. A guest with write access to any sandboxed directory can read and write any host-accessible file, and read-only guests may read host files via preexisting symlinks.
CVE-2026-115389 is a resource allocation vulnerability in bytecodealliance's wasmtime affecting versions before 36.0.16, between 37.0.0 and before 48.0.3, and between 49.0.0 and before 49.0.1. The issue arises because wasmtime does not properly account for host memory allocations when lifting guest values via the Val API, allowing a malicious WebAssembly guest to allocate significantly more host memory than tracked. This can lead to denial of service due to resource exhaustion. The vulnerability has a low severity rating and no known exploits in the wild. No patch links are provided in the input data.
wasmtime-wasi-http in Wasmtime before 36.0.16, 37.0.0 before 48.0.3, and 49.0.0 before 49.0.1 does not enforce the wasi:io/streams check-write allowance for WASIp2 outgoing HTTP bodies, so oversized writes succeed instead of trapping. A malicious guest can pass large buffers to write on outgoing-body resources, holding host allocations for the store's lifetime and exhausting host memory.
Wasmtime before 36.0.17, 37.0.0 before 48.0.4, and 49.0.0 before 49.0.2 contains an information disclosure vulnerability in the WASIp1 fd_readdir implementation that copies uninitialized struct padding into guest memory. Guests with a preopened directory can list entries to receive three bytes of leftover host stack or heap memory per directory entry.
Wasmtime before 36.0.17, 37.0.0 before 48.0.4, and 49.0.0 before 49.0.2 contains an unbounded memory allocation in the wasmtime-wasi WASIp2 write-zeroes method of SinkOutputStream, the default stream used when stdout/stderr are not configured. A malicious WebAssembly guest can request huge zero-filled writes, exhausting host memory and causing denial of service.
Wasmtime before 36.0.17, 37.0.0 before 48.0.4, and 49.0.0 before 49.0.2 contains a denial of service vulnerability in the wasmtime-wasi WASI preview 0 poll_oneoff adapter, which performs O(n) host work per subscription without consuming or checking fuel. Malicious guest modules can pass many subscriptions to force long-running host computation that ignores configured fuel limits.
Two critical remote code execution vulnerabilities in PHP, collectively named PHP2Shell, were disclosed on October 21, 2026. CVE-2026-109618 involves out-of-memory handling corruption that can interrupt PHP while internal request data is partially initialized, leading to invalid data treatment. CVE-2026-109619 exploits stale global state where request-owned internal state survives after memory is freed. Both vulnerabilities can be exploited successfully on ARM64 systems and x86 systems without ASLR. Fixed versions include PHP 8.5.12, 8.4.27, 8.3.36, and 8.2.35. Over 2.6 million internet-facing hosts running PHP were identified as vulnerable, with 42% on end-of-life branches receiving no official patches. Early exploitation attempts were observed from multiple sources, including scanning activity and webshell deployment attempts targeting the upload-progress vulnerability path.
AWS Threat Intelligence detected exploitation attempts of the PHP2Shell vulnerabilities (CVE-2026-109618 and CVE-2026-109619) starting on October 17, 2026, four days before the public disclosure and patch release on October 21, 2026. Multiple actors used anonymized infrastructure to target honeypots and real systems, with proof-of-concept exploits appearing immediately after the embargo lifted. Fixed PHP versions 8.5.12, 8.4.27, 8.3.36, and 8.2.35 address these vulnerabilities, with backports available for versions 7.4 through 8.1. The event highlights the shrinking window between patch release and exploitation and the need for proactive detection and investigation starting before public disclosure.
Two critical PHP vulnerabilities, CVE-2026-109618 and CVE-2026-109619, allow unauthenticated remote code execution. These bugs were discovered in August 2026 and patched by PHP on October 21, 2026, with updates for versions 8.5.12, 8.4.27, 8.3.36, and 8.2.35. Exploitation attempts were detected before and after the patch release, including mass exploitation attempts shortly after fixes were published. Multiple vendors and governments have issued advisories urging immediate patching and thorough discovery of PHP installations, including those embedded in other software. Some organizations temporarily took affected sites offline to mitigate risk. Security firms have released detections and mitigations, and many vendors are reviewing their products for exposure. The vulnerabilities require precise conditions for exploitation but have been actively targeted in the wild.
fzf versions 0.36.0 through 0.74.5 have an inefficient algorithmic complexity vulnerability in the maskActionContents function. This flaw allows local attackers to exhaust the --listen HTTP server by sending large POST requests, causing the single-threaded server to block for approximately 30 seconds per request. The vulnerability results from quadratic string concatenation, leading to resource exhaustion on the affected server.
CVE-2026-114139 is a critical vulnerability in the Sentry-Javascript SDK's webpack integration for @sentry/nextjs. Versions from 9.36.0 up to but not including 9.47.2, 10.0.0-alpha.0 up to 10.75.2, and 11.0.0-alpha.0 up to 11.0.0-rc.1 are affected. The issue arises when the configured tunnelRoute causes the webpack integration to skip application middleware for request paths under that route, allowing unauthenticated requests to reach protected routes if they collide with the tunnel path or a root dynamic segment. This can lead to unauthorized access when middleware is the sole authorization mechanism. The vulnerability is fixed in versions 9.47.2, 10.75.2, and 11.0.0-rc.1.