The kernel packages contain the Linux kernel, the core of any Linux operating system.
Security Fix(es):
* kernel: Linux kernel: Denial of Service in libceph OSD client due to unreset sparse-read state (CVE-2026-23136)
* kernel: Linux kernel: Use-after-free in traffic control (act_ct) may lead to denial of service or privilege escalation (CVE-2026-23270)
* kernel: nfsd: fix heap overflow in NFSv4.0 LOCK replay cache (CVE-2026-31402)
* kernel: crypto: algif_aead - Revert to operating out-of-place (CVE-2026-31431)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Multiple security vulnerabilities have been identified in OpenSSH, including privilege escalation via the scp legacy protocol, security bypass due to mishandling of authorized_keys principals option, information disclosure from unintended cryptographic algorithm usage, low integrity impact from unconfirmed proxy-mode multiplexing sessions, and arbitrary command execution through shell metacharacters in usernames. These issues affect various versions of OpenSSH prior to the fixed releases 8.7p1-49.el9_7.alma.1 and 0.10.4-5.49.el9_7.alma.1. A security update addressing these vulnerabilities is available and recommended for affected systems.
A security vulnerability in libtiff allows for arbitrary code execution or denial of service due to a signed integer overflow in TIFF file processing. This issue affects libtiff versions prior to 4.4.0-15.el9_7.3. A security update addressing this vulnerability is available from Red Hat.
A privilege escalation vulnerability exists in the libcap library due to a time-of-check to time-of-use (TOCTOU) race condition in the cap_set_file() function. This flaw allows an attacker to potentially escalate privileges by exploiting the race condition. A security update fixing this issue is available in libcap version 2.48-10.el9_7.1 for Red Hat Enterprise Linux 9.
A privilege escalation vulnerability exists in the sudo utility due to failure in privilege drop calls. This flaw allows certain users to gain elevated privileges improperly. The issue affects sudo versions prior to 1.9.5p2-15.el9_7. A security update addressing this vulnerability is available and has been released by Red Hat for multiple Red Hat Enterprise Linux 9 variants.
A race condition vulnerability in PackageKit allows arbitrary package installation as root. PackageKit is a D-Bus abstraction layer used for secure package management across distributions and architectures. This vulnerability affects versions prior to 1.2.6-2.el9_7 and has been addressed in the fixed version 1.2.6-2.el9_7. The issue is rated as Important by Red Hat and impacts Red Hat Enterprise Linux 9 and related variants.
A heap-based buffer overflow vulnerability exists in gdk-pixbuf2 when processing specially crafted JPEG images, leading to a denial of service condition. This affects versions prior to 2.42.6-6.el9_7.1. The issue has been rated as Important by Red Hat and fixed in version 2.42.6-6.el9_7.1.
A security vulnerability in Grafana allows information disclosure of data-source passwords via public dashboards. This issue affects versions of Grafana prior to 10.2.6-20.el9_7. A patch is available to address this vulnerability.
A denial of service vulnerability (CVE-2026-34986) exists in the buildah package due to an issue in the Go JOSE library when processing crafted JSON Web Encryption (JWE) objects. This vulnerability can cause buildah to become unresponsive or crash when handling maliciously crafted JWE data. The issue has been addressed in buildah version 2:1.41.8-3.el9_7 and later.
A double-free vulnerability in giflib, a library for reading and writing GIF images, can lead to memory corruption. This issue is tracked as CVE-2026-23868. A security update fixing this vulnerability is available in giflib version 5.2.1-9.el9_7.1. The vulnerability has been rated as Important by Red Hat Product Security.
The image-builder tool, used for creating customized OS artifacts such as VM images and OSTree commits, has a security update addressing multiple vulnerabilities in underlying Go libraries. Notably, CVE-2025-61729 is a denial of service vulnerability caused by excessive resource consumption when processing crafted certificates in the crypto/x509 package. Other related fixes address memory exhaustion in net/url parsing and unexpected session resumption in crypto/tls. The issue affects versions of image-builder prior to 31-3.el9_7.