Chainlit version 2.12.0 contains a server-side request forgery (SSRF) vulnerability. This flaw allows unauthenticated attackers to bypass path-scoped MCP allowed_urls restrictions by exploiting improper validation of semicolon characters in URLs. Attackers can submit specially crafted URLs with '..;' segments to the /mcp endpoint, enabling requests to unauthorized paths on origins that strip semicolon path parameters. The vulnerability has a CVSS 4.0 base score of 6.3, indicating medium severity.
Wing FTP Server before 8.2.6 contains a stored cross-site scripting vulnerability that allows authenticated web-client users to inject script by sending a crafted nowpath parameter to webclient/makethumb.html. Attackers can break out of the directory CDATA section in admin_get_lastconn.html XML to forge a connection id, which executes in administrators' browsers when admin_connection_list.html auto-refreshes, enabling Lua console abuse.
Outline before 1.12.0 contains an incorrect authorization vulnerability in authorizeDocumentPublish() that allows authenticated members to publish documents into private collections without write access. Attackers can detach a child document via documents.unpublish, retaining parentDocumentId, then call documents.update with a private collection UUID to inject phishing content.
LaraDashboard versions before 1.4.9 have a stored cross-site scripting (XSS) vulnerability. Authenticated users with post.create or post.edit permissions can inject malicious scripts via unsanitized LaraBuilder design_json block content. This allows script or event-handler markup to execute in administrator or Superadmin sessions when viewing the builder, preview, or page. The vulnerability is fixed in version 1.4.9.
LaraDashboard versions before 1.4.5 have an incorrect authorization vulnerability in the SettingPolicy::manageCoreUpgrades() function. This flaw allows administrators without Superadmin privileges but with settings.edit permission to perform Superadmin-only core upgrade operations. Exploitation enables access to backup, download, restore, and upgrade actions that can expose database dumps containing password hashes and allow site restoration or upgrades.
Jpom through 2.11.12 contains a cross-workspace authorization bypass in POST /node/ssh_command/batch that resolves command templates and SSH nodes by ID without workspace filtering. Authenticated users with SSH command execute permission in one workspace can supply foreign template and node IDs to run commands on other workspaces' SSH hosts using their stored credentials.
Jpom through 2.11.12 contains a cross-workspace authorization bypass vulnerability that allows authenticated users to manage other workspaces' Docker hosts by supplying foreign Docker asset ids. Attackers with Docker permission in any workspace can control containers, images, volumes and networks, including creating privileged containers with host bind mounts.
python-jose versions up to 3.5.0 contain a critical authentication bypass vulnerability due to improper verification of cryptographic signatures. The issue arises because HMACKey and CryptographyHMACKey accept zero-length HMAC secrets, allowing attackers to forge JSON Web Tokens (JWTs) with arbitrary claims when the verification key is empty. This flaw affects HS256, HS384, and HS512 algorithms and can lead to unauthorized access if exploited.
CVE-2026-120458 is an infinite loop vulnerability in Ultra Video Group's Kvazaar encoder up to version 2.3.2. It occurs in the read_header() function when processing a truncated Y4M header lacking a terminating newline. This causes the encoder to hang indefinitely, consuming a full CPU core.
libaec through 1.1.7 contains an out-of-bounds read vulnerability in m_se_decode() in src/decode.c that allows attackers to bypass a signed bounds check via an overlong fundamental sequence. Attackers can supply a crafted CCSDS 121.0/SZIP stream with 2^31 or more zero bits to crash the decoder or leak adjacent memory into decoded samples.
L-SMASH through 2.14.5 contains a heap out-of-bounds write vulnerability in isom_read_hdlr() and isom_read_dref_entry() in core/read.c triggered by oversized box sizes. Attackers can supply crafted MP4 or MOV files declaring hdlr or url box sizes larger than remaining data, stalling the stream position and corrupting heap memory to crash applications.
CVE-2026-120455 is an out-of-bounds write vulnerability in rapidyaml versions up to 0.16.0. It occurs in the ParseEngine::_add_annotation() function when processing YAML input with excessive anchors or tags, leading to stack memory corruption and potential process crashes.
The Sleuth Kit up to version 4.15.0 has a NULL pointer dereference vulnerability in the decmpfs_decompress_lzvn_attr() function. This flaw can be triggered by supplying a crafted HFS+ image with a specially manipulated LZVN inline com.apple.decmpfs attribute that sets an excessively large uncompressed size. The vulnerability causes a denial of service by crashing the tool due to a failed allocation and subsequent NULL pointer write.
The Sleuth Kit through 4.15.0 contains a heap out-of-bounds read vulnerability in hfs_load_extended_attrs() in tsk/fs/hfs.c that reads the decmpfs header without checking attribute length. Attackers can supply a crafted HFS+ image with a com.apple.decmpfs attr_size of 1 to 15 to read past the allocation and crash analysis tools like istat or icat.
libgphoto2 through 2.5.34 contains a heap out-of-bounds read and write vulnerability in jl2005bcd_decompress() that allows malicious USB cameras to corrupt heap memory via oversized thumbnail processing. Attackers can supply small allocation-table values and a thumbnail header byte so in-place byte-swapping exceeds the buffer by about 30 KB, leaking heap contents in preview images.
CVE-2026-120451 is a high-severity vulnerability in libgphoto2 up to version 2.5.34. It involves stack-based and heap-based buffer overflows in the jl2005c_init() function caused by malicious USB devices supplying an unbounded allocation table entry count. This can lead to memory corruption, including overwriting the saved return address and heap data, potentially allowing code execution.
LaraDashboard versions 1.4.0 through 1.4.8 contain an improper authorization vulnerability allowing authenticated users with read-only email_template.view permission to send arbitrary emails via the MCP send-email tool. This flaw enables attackers to mint an MCP token and send emails with arbitrary recipients, subjects, and HTML bodies, potentially facilitating phishing or spam campaigns. The issue is fixed in version 1.4.9.
Outline before 1.12.0 contains an improper access control vulnerability that allows unauthenticated users to read unpublished documents because the share loader ignores unpublished status. Attackers holding an existing share link can query shares.info, documents.info, or the /s/ share routes to read withdrawn content, while shares.revoke returns 404 and blocks revocation.
DoraCMS through 3.1.0 contains a mass assignment vulnerability in the PUT /api/v1/user/api-keys/:id endpoint that allows authenticated low-privileged users to rebind their API key to another user's account. Attackers can set the userId field on their own key to a victim's id, then act as that victim to modify profiles and publish or delete content.
HotGo versions up to 2.15.1 have an authentication bypass vulnerability that allows attackers to set the SMS login verification code by manipulating the /admin/sms/send endpoint. This enables attackers who know a user's mobile number to authenticate as that user, including administrator accounts, via /admin/site/mobileLogin.