Multiple security issues were identified in the libXi client-side library for the X Input Extension, leading to a high-severity vulnerability tracked as CVE-2026-109089. These issues affect versions prior to 1.8.1-6.oe2403sp3 and have been addressed in the fixed release 1.8.1-6.oe2403sp3. The vulnerability has a CVSS 3.1 score of 7.5, indicating high impact on confidentiality, integrity, and availability.
Squid proxy server versions from 3.3.0.1 up to but not including 7.6 are vulnerable to an HTTP Request Smuggling attack due to improper enforcement of HTTP/1.1 Transfer-Encoding header parsing. This flaw allows a trusted client to bypass security controls and potentially poison upstream HTTP caches with malicious content. The vulnerability is fixed in Squid version 7.6.
CVE-2026-95838 is a vulnerability in containerd, an industry-standard container runtime. Prior to versions 1.7.35, 2.0.12, 2.2.8, and 2.3.5, the layer unpack handler in containerd repeatedly traverses directories when processing certain opaque whiteout configurations. A malicious image layer can exploit this to cause repeated directory traversals, leading to high CPU usage, delayed container startup, and reduced image-pull concurrency for unrelated deployments. This issue has been fixed in the specified versions.
Libsndfile version prior to 1.0.31-7.oe2203sp4 contains a vulnerability in the psf_binheader_readf() function when parsing WAV fmt chunks. This flaw involves a misaligned memory access that can cause undefined behavior and lead to a denial of service when processing specially crafted WAV files. The issue is fixed in version 1.0.31-7.oe2203sp4.
A use-after-free vulnerability in libarchive's archive_entry_copy_mac_metadata() function can lead to denial of service or potential information disclosure. The flaw occurs because an internal buffer is deallocated before data copying completes, allowing attackers supplying crafted input to crash the application or read uninitialized memory. This affects versions prior to 3.7.1-14.oe2403sp4. A patch is available to address this issue.
Multiple critical vulnerabilities have been identified in Apache Tomcat affecting versions from 7.0.0 through 11.0.26, including authentication bypass, request/response mix-up, failure to securely enforce FIPS mode, execution after redirect, local unauthorized access via TOCTOU race condition, and incomplete cleanup issues causing data leakage and TLS 1.3 connection failures. These vulnerabilities allow attackers to bypass authentication, cause data leakage between users, and potentially disrupt secure communications. Fixed versions are available and users are strongly advised to upgrade to 11.0.27, 10.1.61, or 9.0.123 to mitigate these issues.
An Execution After Redirect (EAR) vulnerability exists in Apache Tomcat's Jasper JSTL <c:redirect> plug-in implementation, where the page abort (SKIP_PAGE) is omitted. This affects multiple versions of Apache Tomcat, including 7.0.0 through 9.0.122, 10.1.0 through 10.1.60, and 11.0.0 through 11.0.26. The issue is fixed in versions 9.0.123, 10.1.61, and 11.0.27.
A vulnerability in virtualenv prior to version 21.14.7 allows command execution via specially crafted environment names containing a backslash before a dollar sign in the bash activate script. This occurs because the script escapes the environment name improperly, leading to execution of commands in the user's shell prompt. The issue is fixed in version 21.14.7.
A buffer overflow vulnerability exists in the Brotli decoder used by Google Brotli versions 1.0.3 through 1.2.0, affecting PowerShell versions 7.4.0 through 7.4.21, 7.5.0 through 7.5.12, and 7.6.0 through 7.6.8. This flaw allows a remote unauthenticated attacker to corrupt adjacent memory, potentially leading to sensitive data disclosure, denial of service, or arbitrary code execution. Fixed versions are 7.4.22, 7.5.13, and 7.6.9.