Skip to main content
CVE-2024-53947VulnerabilityPublished Updated

CVE-2024-53947: Apache Superset · Improper SQL authorisation, parse not checking for specific postgres functions

Affects supersetSource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited : upgrade to 4.1.1 as a priority.

Data as of 26 Oct 2026, 06:26 UTC

Severity
Critical

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.1.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade superset to 4.1.1.

Affected software

ProductAffectedFixed in
Bitnamisupersetpkg:bitnami/supersetOther threatsAffected
  • <4.1.1
Fixed in
  • 4.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache Superset to version 4.1.1 or later, which includes the fix for this vulnerability. Alternatively, users can manually add the PostgreSQL functions query_to_xml_and_xmlschema, table_to_xml, and table_to_xml_and_xmlschema to the DISALLOWED_SQL_FUNCTIONS configuration setting to mitigate the issue.

Description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Superset. Specifically, certain engine-specific functions are not checked, which allows attackers to bypass Apache Superset's SQL authorization. This issue is a follow-up to CVE-2024-39887 with additional disallowed PostgreSQL functions now included: query_to_xml_and_xmlschema, table_to_xml, table_to_xml_and_xmlschema. This issue affects Apache Superset: <4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue or add these Postgres functions to the config set DISALLOWED_SQL_FUNCTIONS.

References

Community reviews

Loading reviews…