Skip to main content
CVE-2023-1389VulnerabilityPublished Updated

CVE-2023-1389: TP-Link Archer AX21 (AX1800) · Command Injection

Affects TP-Link Archer AX21 (AX1800)Source CVE Database V5

0

Exploited in the wild · KEV due 22 May 2023 · public exploit available (Exploit-DB) · 99% EPSS : upgrade to 1.14 now.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else.
EPSS
99.9% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.14
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 15 Mar 2023

  2. Exploited in the wild: evidence found.

    Listed in CISA KEV 47 days after disclosure

  3. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by Tenable Network Security, Inc.

    , 1 day before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. , 47 days after disclosure

  4. KEV remediation due

    US federal deadline

    , 68 days after disclosure

  5. First Exploit-DB entry (opens in a new tab)

    TP-Link Archer AX21 - Unauthenticated Command Injection

    , 148 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade TP-Link Archer AX21 (AX1800) to 1.14.

Affected software

ProductAffectedFixed in
TP-Link TP-Link Archer AX21 (AX1800)Affected
  • <1.14
Fixed in
  • 1.14

Check the firmware or software version for TP-Link Archer AX21 (AX1800) in the device's admin interface against the vendor advisory.

Description

TP-Link Archer AX21 (AX1800) firmware versions before 1.1.4 Build 20230219 contained a command injection vulnerability in the country form of the /cgi-bin/luci;stok=/locale endpoint on the web management interface. Specifically, the country parameter of the write operation was not sanitized before being used in a call to popen(), allowing an unauthenticated attacker to inject commands, which would be run as root, with a simple POST request.

References

Community reviews

Loading reviews…