Skip to main content
CVE-2023-42501VulnerabilityPublished Updated

CVE-2023-42501: Apache Superset · Incorrect Default Permissions

Affects Apache SupersetSource CVE Database V5

0

Not known to be exploited · CVSS 4.3 Medium : upgrade to 2.1.2 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 58% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.1.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Nov 2023

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade apache-superset to 2.1.2.

Affected software

ProductAffectedFixed in
PyPIapache-supersetpkg:pypi/apache-supersetOther threatsAffected
  • <2.1.2
Fixed in
  • 2.1.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Upgrade Apache Superset to version 2.1.2 or later immediately to ensure the Gamma role permissions are corrected by default. 2. After upgrading, execute the `superset init` command to reconstruct the Gamma role with the appropriate permissions. 3. If upgrading is not immediately feasible, manually remove the `can_read` permission from CSS templates and annotations for the Gamma role via Superset's role and permission management interface. 4. Audit existing user roles and permissions regularly to ensure no excessive privileges are granted, especially for roles with read access to configuration or UI resources. 5. Implement strict authentication and authorization controls to limit the assignment of the Gamma role only to trusted users. 6. Monitor Superset logs for unusual access patterns to CSS templates and annotations that could indicate exploitation attempts. 7. Educate administrators and developers about the importance of least privilege principles in BI tool configurations. 8. Consider network segmentation and access controls to restrict Superset access to authorized personnel only.

Description

Unnecessary read permissions within the Gamma role would allow authenticated users to read configured CSS templates and annotations. This issue affects Apache Superset: before 2.1.2. Users should upgrade to version or above 2.1.2 and run `superset init` to reconstruct the Gamma role or remove `can_read` permission from the mentioned resources.

References

Community reviews

Loading reviews…