Skip to main content
CVE-2023-49096VulnerabilityPublished Updated

CVE-2023-49096: jellyfin · Argument Injection

Affects jellyfinSource CVE Database V5

0

Not known to be exploited · CVSS 7.7 High : upgrade to 10.8.13 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.2% chance of exploitation in 30 days – higher than 69% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.8.13
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Dec 2023

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade jellyfin/jellyfin to 10.8.13.

Affected software

ProductAffectedFixed in
GitHubjellyfin/jellyfinpkg:github/jellyfin/jellyfinOther threatsAffected
  • <10.8.13
Fixed in
  • 10.8.13

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Immediate upgrade of all Jellyfin instances to version 10.8.13 or later, where the vulnerability is patched, is the most effective mitigation. 2. Restrict network access to Jellyfin servers by implementing firewall rules or VPN access, limiting exposure to the internet and reducing the attack surface. 3. Monitor server logs for unusual requests to the vulnerable endpoints, especially those containing suspicious query parameters like `videoCodec` and `audioCodec`. 4. Employ application-layer filtering or web application firewalls (WAFs) to detect and block malformed or suspicious requests targeting the vulnerable endpoints. 5. Conduct regular audits of media item IDs and access patterns to detect potential reconnaissance attempts aimed at guessing valid GUIDs. 6. Isolate Jellyfin servers in segmented network zones with minimal privileges to limit potential lateral movement if compromised. 7. Educate administrators about the risks of exposing media servers publicly and encourage secure deployment practices. Since no workarounds exist, patching combined with network-level controls and monitoring is critical.

Description

Jellyfin is a Free Software Media System for managing and streaming media. In affected versions there is an argument injection in the VideosController, specifically the `/Videos/<itemId>/stream` and `/Videos/<itemId>/stream.<container>` endpoints which are present in the current Jellyfin version. Additional endpoints in the AudioController might also be vulnerable, as they differ only slightly in execution. Those endpoints are reachable by an unauthenticated user. In order to exploit this vulnerability an unauthenticated attacker has to guess an itemId, which is a completely random GUID. It’s a very unlikely case even for a large media database with lots of items. Without an additional information leak, this vulnerability shouldn’t be directly exploitable, even if the instance is reachable from the Internet. There are a lot of query parameters that get accepted by the method. At least two of those, videoCodec and audioCodec are vulnerable to the argument injection. The values can be traced through a lot of code and might be changed in the process. However, the fallback is to always use them as-is, which means we can inject our own arguments. Those arguments land in the command line of FFmpeg. Because UseShellExecute is always set to false, we can’t simply terminate the FFmpeg command and execute our own. It should only be possible to add additional arguments to FFmpeg, which is powerful enough as it stands. There is probably a way of overwriting an arbitrary file with malicious content. This vulnerability has been addressed in version 10.8.13. Users are advised to upgrade. There are no known workarounds for this vulnerability.

References

Community reviews

Loading reviews…