Skip to main content
CVE-2024-11235VulnerabilityPublished Updated

CVE-2024-11235: PHP · Use After Free

Affects PHPSource CVE Database V5

0

Not known to be exploited · CVSS 9.2 Critical : upgrade to 8.4.5 or 8.3.19 as a priority.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.4% chance of exploitation in 30 days – higher than 73% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.4.5, 8.3.19
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/U:Amber

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade php/php to 8.4.5 or 8.3.19.

Affected software

ProductAffectedFixed in
Phpphp/phppkg:deb/php/phpOther threatsAffected
  • <8.3.19
  • <8.4.5
Fixed in
  • 8.3.19
  • 8.4.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Immediately upgrade PHP to versions 8.3.19 or 8.4.5 or later, where the vulnerability is patched. 2. Review and audit PHP codebases for usage of the __set magic method and the ??= operator, especially in conjunction with exception handling, to identify potentially vulnerable code paths. 3. Employ web application firewalls (WAFs) with updated rules to detect and block suspicious payloads that might attempt to exploit this vulnerability. 4. Implement strict input validation and sanitization to reduce the risk of crafted inputs manipulating memory layout. 5. Monitor logs and network traffic for unusual activity indicative of exploitation attempts, such as unexpected PHP errors or abnormal requests targeting vulnerable endpoints. 6. Isolate critical PHP applications in segmented network zones to limit potential lateral movement if exploited. 7. Maintain an up-to-date inventory of PHP versions in use across the organization to prioritize patching efforts. 8. Consider deploying runtime application self-protection (RASP) solutions that can detect and block exploitation attempts in real time. 9. Educate development teams about secure coding practices related to PHP magic methods and exception handling to prevent similar vulnerabilities.

Description

In PHP versions 8.3.* before 8.3.19 and 8.4.* before 8.4.5, a code sequence involving __set handler or ??=  operator and exceptions can lead to a use-after-free vulnerability. If the third party can control the memory layout leading to this, for example by supplying specially crafted inputs to the script, it could lead to remote code execution.

References

Community reviews

Loading reviews…